Category: техника

Category was added automatically. Read all entries about "техника".

eyes

Интернет постабильнее далеко за городом

Столкнулся с проблемой -- едешь себе куда подальше от цивилизации (но ещё в пределах сотовых сетей) и тут тебе срочно звонят с работы нужно залить видео в инстаграм.
А интернет на берегу Байкала, например, переменчив -- то LTE, то парой метров дальше, EDGE. То вообще нет.

Сначала смотрел в сторону автомобильной системы, например такой: BAS-2328 Интернет в машине.
Выглядит неплохо (там внутре неонка хуавеевский модем и антенны, если кому интересно), но здравый смысл подсказывает, что если в одном мест интернеты есть, а чуть дальше нет -- это, вероятно, из-за рельефа местности и с этим надо что-то делать.

Поскольку дома у меня микротик, смотрел в их сторону.
Пришёл к сетапу: MikroTik wAP LTE Kit и антенну к нему (впрочем, насчёт антенны не уверен).

Закинуть в машину и пусть интернеты раздаёт. Приехал на Байкал, воткнул мачту раздвижную, поднял его метров на пять и снова пусть раздаёт. Для питания взять mUPS и батарею от ИБП на 7Ач.

Теперь вопросы:
1. есть ли у меня ошибка в рассуждениях (ну, кроме "нахрена тебе это всё за городом?". Нужно. Увы.)
2. делал ли кто-нибудь что-то подобное? Наверняка я не первый такой упоротый? Из чего делали, где брать мачту, какие подводные камни?
  • dil

А тут кто-нибудь знает, как настроить среднюю кнопку на тачпаде ноутбука?

В ru-debian пока никаких ответов на этот вопрос нет.

Итак, ноутбук Dell. У него на тачпаде снизу две кнопки - левая и правая, а сверху ещё три - левая, средняя и правая.
В установленном там Debian'е 8.11 все эти кнопки работают, значит, никаких физическх дефектов точно нет.

Но когда я на этом же ноутбуке запускаю с внешнего USB-диска более свежий Debian (9.8), то левые и правые кнопки работают, но когда я нажимаю на среднюю, например, чтобы в браузере открыть по ссылке новую вкладку, совершенно ничего не происходит. Если нажать одновременно на обе нижние кнопки, то это срабатывает как средняя.

А если на среднюю кнопку быстро нажать 2-3 раза, то новые вкладки открываются, обычно 2-3 раза, хотя иногда только одна, как и надо.
Отчего такое может быть, и как это можно подправить?

Читалки Atom и RSS для Linux

Здравствуйте. Хочу поинтересоваться у участников сообщества. Какими читалками (агрегаторами) Atom и RSS вы пользуетесь под Linux? И поясните, почему вы выбрали именно эту программу (плюсы, минусы). Примечание: меня интересуют десктопные приложения, а не плагины для браузеров и не web-приложения, запускаемые в браузерах.
tux
  • oyx

Качество звука в bluetooth

Имеется вот такой девайс: SVEN AP-B550MV. Под win7 никаких проблем со звуком нет. Но под Mint 18 просто днище: звук как будто из ведра, накрытого кучей тряпок. С другими гарнитурами/колонками etc всё хорошо. Куда копать? Да, Pulse.
  • dil

Как посмотреть cheese'ом в видеокамеру?

Встроенная в ноутбук видеокамера, подключённая по USB (ID 0c45:64af), нормально работает в cheese (версия 3.22.1).
А вот когда я втыкаю внешнюю (ID 1908:3256), cheese запускается, но почему-то сразу выбирает эту дополнительную камеру, и в своём окне показывает только надпись "There was an error playing video from the webcam".

В консоли вылезает ошибка Collapse )
  • dil

Linux на Lenovo

Кто-нибудь знает, насколько ноутбуки Lenovo совместимы с линуксом?
В частности, меня интересует модель 80T7000DUK (процессор Intel Pentium N3710, видео Intel HD Graphics 405)
плюс USB 2/3, wifi 802.11 ac/a/b/g/n, ethernet10/100, видеокамера, touchpad - неизвестных производителей, поэтому определить совместимость трудновато.

С Dell'овскими я уже много лет работаю, и знаю, что линукс практически на всех нормально уживается. А с Lenovo никогда дела не имел. Продаются они исключительно с 10 виндой, а мне нужен линукс.

Upd: спасибо всем комментаторам! Судя по ответам, линукс на Lenovo вполне успешно работает, так что, может я теперь и сам попробую.
tux
  • oyx

Пропадает курсор мыши

2 ноутбука, на одном Mint 18/xfce, на другом win7. Мышь, клавиатура и отдельный монитор подключены через KVM (если это важно - Aten CS22U). Внешний монитор настроен как дополняющий сбоку в обоих случаях.

[Схематично в картинке]

С переключением никаких проблем нет, всё работает на ура. Но одна мелочь: после переключения внешнего монитора с win на mint на линуксовом мониторе ноутбука пропадает курсор мыши. Причём сама мышь работает, клики на нём отрабатывают (если получится угадать где нужно кликать), на внешнем мониторе курсор видно. Лечится закрытием активного на момент переключения окна на ноутбуке.

Есть идеи как с этим бороться?
  • dil

Теперь линукс таки работает с тем андроидом..

В продолжение поста "Линукс не работает с андроидом". На случай, если у кого встретится аналогичная проблема, делюсь своим решением.

Проблема: при втыкании смартфона в ноутбук линукс сообщал, что видит подключённое андроидное устройство, но показывал только тамошний виртуальный CD-ROM. А вот файловая система самого смартфона (по MTP) почему-то оказывалась совершенно недоступна, и adb этого смартфона не видел, и fastboot тоже.

Этот дефект проявлялся только на одном экземпляре линукса, и только при втыкании смартфона в уже загруженную систему. Если смартфон воткнуть до загрузки, или в другой линукс, или в винду (даже в виртуальную на том же самом невидящем его линуксе), то все они нормально видели файловую систему смартфона по MTP, и adb работал.

Оказалось, что при втыкании смартфона в тот уже загруженный линукс, на этом USB-устройстве почему-то обнаруживалась пачка серийных портов от GSM-модемов. Хотя в смартфоне и мобильный интернет, и wifi, и USB tethering были выключёны. И из-за этого подгружались модули usbserial, usb_wwan, и ещё какой-то option. Вот этот option и вызывал проблемы. Во всех других вариантах подключения ничего подобного не обнаруживалось, лишние модули не грузились, и потому всё нормально работало.
Collapse )
  • dil

Линукс не работает с андроидом

У меня, как всегда, загадочные грабли..

Имеется китайский смартфон (Huawei Honor 8) с 6 андроидом. Пытаюсь его зарутить, работаю, как обычно, из линукса (Debian 8.7) с ноутбука. И пару дней назад этот линукс внезапно перестал нормально общаться с этим андроидом. То есть, при втыкании смартфона в USB-порт линукс в целом его видит, но:

1) внутренний диск [показывается с именем самого смартфона - FRD AL10] иногда успешно открывается по MTP, а иногда только показывается в гномовском Наутилусе, причём без Mount/Unmount в локальном меню, а при попытке в него зайти: Unable to access "FRD AL10"-Unable to open MTP device '[usb:002,003]'
2) виртуальный CD [на котором лежит некий 华为手机助手安装向导.exe (кажется, это родное хуавейское приложение под винду - HiSuite), и pdf с копирайтами на opensource'ный софт] иногда успешно монтируется (не по MTP, а как обычный CD - /dev/sr0), иногда вообще не видится
3) и главное - adb этого смартфона вообще не видит, в самом смартфоне запросов на разрешение USB debugging не вылезает
4) если смартфон воткнуть в режиме bootloader'а, то fastboot devices его показывает, но при вводе ЛЮБОЙ команды, даже fastboot reboot, выдаёт < waiting for any device >, и ждёт до бесконечности.

Сначала я подумал, что это что-то в смартфоне попортилось, но попробовал воткнуть его в винду на том же самом ноутбуке, а там всё успешно работает.
А сегодня воткнул его в десктоп (с тем же самым Дебианом 8.7), всё работает. Запустил adb (та же версия, что на нотбуке - 1.0.36 Revision 302830efc153-android) - тоже работает. Попробовал обратно на ноутбуке - не работает, точно как описано выше.

Есть у кого идеи, отчего такое может быть, и как его вылечить?

Upd: Мой линукс живёт на внешнем USB-диске. Я попробовал запустить его на другом ноутбуке, и там всё так же не работает. А из точно такого же Debian'а, установленного на самом этом ноутбуке, всё работает.

С другими смартфонами (HTC Desire S, Desire X, HTC One) и с моего внешнего диска всё успешно работает с обоих ноутбуков. А вот с Honor8 почему-то нет..

Выходит, что дело не в железе, не в ядре, не в драйверах и вообще не в самом линуксе, а в одном конкретном экземпляре его. Но ЧТО там может быть не так???

Upd2: Если смартфон подключить ДО загрузки линукса, то он успешно видится и по MTP, и через adb. А вот если его подключить к уже загруженному линуксу, тогда он стабильно не видится, как описано выше..
поумнеть

cups

есть ноутбук в беспроводной сетке 192.168.113/24.
есть wl500gp роутер между 113, 111 сетями и интеретом (192.168.111.5, он же шлюз по умолчанию, 113 беспроводная, 111 по проводу).
есть бывший уже убитый сервер eee701 192.168.111.11 с самбой, купсом, owfs, апачем и фидо.
есть новый eee2 сервер 192.168.111.19.

везде дебиан32-стэйбл. сношу на ноутбуке купс (пурж, а не ремув), ставлю на ноутбуке и на еее2 купс и внезапно эти купсы как-то фантомно видят принтер на уже убитом еее701 и на ноутбуке. ага, один и тот же бразер-хп-1110 виден в трёх местах. Естественно, эта порнография работает неправильно.

собственно вопрос, как всем этим купсам объяснить, что вот тех двух принтеров нет и не будет, но есть вот этот и его надо по умолчанию? на половину действий купсы выдают страницу с невнятной тупой надписью "запрещено" без попыток запросить админский пароль.