nickita startcev (nicka_startcev) wrote in ru_linux,
nickita startcev
nicka_startcev
ru_linux

Category:

10g ethernet

кривой вопрос.

есть двухголовая карточка, интел. под нее встают драйвера ixgbe - перепробовал несколько версий с сайта интела и с патчами на работу на 1г от вендора. (вендор - интел, конкретную модель могу глянуть завтра, модели трансиверов - тоже завтра)

ос - дебиан.

при работе вылезают странности
1. от перезагрузки (холодной) к перезагрузке карточка ведет себя по-разному - то идут пинги то не идут, при этом лампочка линк горит
2. если вынуть из карточки трансиверы, вставить обратно - пинги гарантированно появляются.
3. то есть, явно, при вытаскивании-втыкании трансивера происходит что-то важное, что драйвер (или железо) не отрабатывает.

куда смотреть, что менять, что еще проверить?
трансиверы есть разные, на 1/10г, на оптику и медь, глюк с "после холодной перезагрузки пинги не ходят, но перетыкание трансивера лечит" воспроизводится достаточно стабильно - с хабом около 100%, с неким глючным клиентом около 60%.

если кто что похожее видел - поделитесь опытом, плиз.

4. можно ли на две головы карточки поставить два разных драйвера? это бы решило часть проблем (ос - дебиан, ядро - последнее из тех, на которое есть i-pipe patch)
Subscribe
  • Post a new comment

    Error

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 5 comments