Пропала, собака ! Или не пропала ?
vlkamov
Нужна была винда буквально на раз, а под рукой как назло ни одного компа и даже HDD, который не жалко. Быль только древний установочный диск XP SP2. И я попытался установить ее на флешку. При установке был честно предупрежден, что перепишется то ли MBR, то ли нулевой сектор, что и произошло.

Установка все равно не получилась, но и флешка теперь тоже .. 300 рублей не деньги, но все же интересно почему даже вставленная в гнездо флешка не видна в /dev

Ubuntu 14.04.5 LTS

Можно ли заставить систему увидеть хотя бы устройство, ладно уж с [авто]монтированием потом разберемся.

Update. Решено [ли ?]
Неудача случилась вчера, сегодня dil посоветовал посмотреть в dmesg,
втыкаю флешку смотрю - появилось /dev/sdb
Правда в dmesg никаких сообщений нет.

Тем не менее проблема вообще все же существует.
Случается, что железяка не работает. Чаще всего советуют найти подходящий драйвер. Но есть ли средства низкоуровневой диагностики ? Например послать в данный разъем некую цепочку нулей-единиц и посмотреть отклик.

Буквально на той неделе было. Раз - и машина не попадает в одну из подсетей. ifconfig кажет, то же что и раньше видели. Вызванный техподдержчик провайдера пришел со своим ноутбуком и говорит: "Видите - у меня все работает". Ставим наш исправный ноутбук - не работает. "Мы ничего не делали".
Я конечно разобрался, что он сбрехал - они нам назначили другой IP, но он же утверждал, что у вас испортилась сетевая карта !

Снова про KVM и не только
tux
oyx
Через железяку подключены только монитор и клавиатура. При этом

1) после переключения на другой компьютер и обратно
2) без переключения - после закрытия/открытия крышки ноута

начинают скакать ID устройств на линуксовой машине. Пример,

[до:]
$ xinput
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=16   [slave  pointer  (2)]
⎜   ↳ SIGMACHIP USB Keyboard                    id=10   [slave  pointer  (2)]
⎜   ↳ OM                                        id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=17   [slave  keyboard (3)]
    ↳ SIGMACHIP USB Keyboard                    id=9    [slave  keyboard (3)]


[и после:]
$ xinput
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=16   [slave  pointer  (2)]
⎜   ↳ SIGMACHIP USB Keyboard                    id=9    [slave  pointer  (2)]
⎜   ↳ OM                                        id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=17   [slave  keyboard (3)]
    ↳ SIGMACHIP USB Keyboard                    id=11   [slave  keyboard (3)]


В принципе было бы пофиг, но висит программулина, которая периодически тыркается во внешнюю клавиатуру, ID которой выдаётся при старте. И, соответственно, теряет её после такого. Варианты? Побороть эти перескоки (если в принципе реально), искать клавиатуру самостоятельно после какого-то события (какого), что-то ещё?
Метки: ,

Чертов ntp!
Костерок
eddy_em
В очередной раз столкнулся с проблемой: пока не было сети, кубитрак, работающий с all-sky, был запущен. Проверяю сейчас — дает картинки, датируемые 15:00. Смотрю системное время — действительно! Я-то думал, там rtc работает, т.к. батарейка какая-то на борту есть, но то ли батарейка сдохла, то ли нет rtc, как и на "малинке".

Проблема в том, что ntp-сервер при старте запускается! И как бы должен системное время корректировать. Фактически же получается, что ntp-сервер имеет своей задачей лишь раздачу системного времени, а коррекцией кто-то другой будет заниматься.

Вопрос: есть ли возможность настроить ntp-сервер так, чтобы он занимался именно коррекцией системного времени, или же нужно каждые 5 минут по крону или еще как-то запускать ntpdate? Дожились, блин!..

UPD: пока модерировали, вопрос с коррекцией решился: параметр -U позволяет уменьшить дефолтный интервал времени между опросами.
Однако, непонятно, почему после восстановления сети все равно не сработала коррекция времени — ключик -g в опциях указан.
Метки:

Linux на Lenovo
dil
Кто-нибудь знает, насколько ноутбуки Lenovo совместимы с линуксом?
В частности, меня интересует модель 80T7000DUK (процессор Intel Pentium N3710, видео Intel HD Graphics 405)
плюс USB 2/3, wifi 802.11 ac/a/b/g/n, ethernet10/100, видеокамера, touchpad - неизвестных производителей, поэтому определить совместимость трудновато.

С Dell'овскими я уже много лет работаю, и знаю, что линукс практически на всех нормально уживается. А с Lenovo никогда дела не имел. Продаются они исключительно с 10 виндой, а мне нужен линукс.

Upd: спасибо всем комментаторам! Судя по ответам, линукс на Lenovo вполне успешно работает, так что, может я теперь и сам попробую.
Метки: ,

Пропадает курсор мыши
tux
oyx
2 ноутбука, на одном Mint 18/xfce, на другом win7. Мышь, клавиатура и отдельный монитор подключены через KVM (если это важно - Aten CS22U). Внешний монитор настроен как дополняющий сбоку в обоих случаях.

[Схематично в картинке]

С переключением никаких проблем нет, всё работает на ура. Но одна мелочь: после переключения внешнего монитора с win на mint на линуксовом мониторе ноутбука пропадает курсор мыши. Причём сама мышь работает, клики на нём отрабатывают (если получится угадать где нужно кликать), на внешнем мониторе курсор видно. Лечится закрытием активного на момент переключения окна на ноутбуке.

Есть идеи как с этим бороться?
Метки: , ,

inittab -> systemd
Костерок
eddy_em
Вопрос: как с минимальными усилиями на чертов systemd перенести такую элементарщину, как запуск сервиса? В sysvinit я пишу строчку вроде "m1:2345:respawn:/my/service", и все работает.
А как быть с systemd (ну нет у меня желания генту вкорячивать на одноплатник, там распбиан стоит)?
Метки:

Как заставить работать wifi адаптер?
dil
Имеется компьютер со встроенным Realtek'овским usb'шным wifi адаптером:
Bus 002 Device 004: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter

Поставил туда свежий Debian (8.7), Network Manager показывает список wifi'ных точек доступа, в том числе и мою, но подключиться почему-то не может. Каждый раз переспрашивает пароль, я его много раз заново вводил, а всё равно не подключается.
Погуглил, пишут, что какая-то версия Network manager'а с этим драйвером криво работает, помогает откат на предыдущую. Ну я Network manager вообще выключил и попробовал настроить всё руками в /etc/network/interfaces, вписав туда wpa-ssid, wpa-psk и статический IP. После перезагрузки компьютера ifconfig показывает wlan0 с правильным IP-адресом, и вроде как UP:
Читать дальше...Свернуть )
Но доступа к wifiной сети на самом деле нет:
Читать дальше...Свернуть )

iwlist wlan0 scan работает, и мою точку доступа видит, значит, дравйер и прошивка вроде как правильные:
Читать дальше...Свернуть ) а подключиться почему-то не может.

Попробовал воткнуть в машину внешний USBшный wifi-адаптер, и он с точно такими же wpa-ssid и wpa-psk в /etc/network/interfaces нормально работает.

Есть у кого идеи, как всё-таки заставить работать встроенный адаптер?
Метки:

Resolved: Загадочная проблема с кодировками
dil
На домашней машинке стоит линукс (Debian 7, если это имеет какое-то значение). Некоторые директории и файлы там названы на русском языке. Локаль хоть и не русская, но UTF-8:
Читать дальше...Свернуть )
так что всё нормально читается и в терминалах, и в mc, и в иксовых приложениях.

Когда я захожу на эту машинку с ноутбука (тоже Debian, только 8, и с такой же локалью) по ssh (или по sshfs), тоже всё нормально.
А вот когда захожу с другой машинки (тот же Debian 8, только кодировка чуточку другая, но тоже UTF-8:
Читать дальше...Свернуть )
то русские названия почему-то нечитабельны. Хотя русские буквы, которые я сам набираю, нормально видятся:Читать дальше...Свернуть )
Метки:

Теперь линукс таки работает с тем андроидом..
dil
В продолжение поста "Линукс не работает с андроидом". На случай, если у кого встретится аналогичная проблема, делюсь своим решением.

Проблема: при втыкании смартфона в ноутбук линукс сообщал, что видит подключённое андроидное устройство, но показывал только тамошний виртуальный CD-ROM. А вот файловая система самого смартфона (по MTP) почему-то оказывалась совершенно недоступна, и adb этого смартфона не видел, и fastboot тоже.

Этот дефект проявлялся только на одном экземпляре линукса, и только при втыкании смартфона в уже загруженную систему. Если смартфон воткнуть до загрузки, или в другой линукс, или в винду (даже в виртуальную на том же самом невидящем его линуксе), то все они нормально видели файловую систему смартфона по MTP, и adb работал.

Оказалось, что при втыкании смартфона в тот уже загруженный линукс, на этом USB-устройстве почему-то обнаруживалась пачка серийных портов от GSM-модемов. Хотя в смартфоне и мобильный интернет, и wifi, и USB tethering были выключёны. И из-за этого подгружались модули usbserial, usb_wwan, и ещё какой-то option. Вот этот option и вызывал проблемы. Во всех других вариантах подключения ничего подобного не обнаруживалось, лишние модули не грузились, и потому всё нормально работало.
Читать дальше...Свернуть )
Метки: , ,

Проброска сетевого интерфейса в docker-контейнер
prividen
prividen
Здравствуйте!

Народ, кто в докер умеет, подскажите пожалуйста, как сейчас "по феншую" правильно оформить проброску одного из сетевых интерфейсов хост-системы внутрь контейнера?
Ручками через ip netsh всё замечательно получается и работает, но как это оформить в виде автоматики для продакшена?

Раньше, говорят, можно было сказать при создании контейнера
--net="none" --lxc-conf="lxc.network.type=phys" --lxc-conf="lxc.network.link=eth3" --lxc-conf="lxc.network.name=eth0"

Но сейчас, в новой версии докера, возможность использовать LXC полностью выпилили и эти опции хоть и принимаются, но не работают.

Сети типа host, bridge, macvlan по разным причинам совершенно не устраивают, нужна именно проброска одного из сетевых интерфейсов.

?

Log in